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Introduction
ReTreeval is an easy to use application that combines a database and a decision 
tree program. To search the database, all you have to do is answer questions in 
natural English asked by ReTreeval. The amount of information stored about each 
item grows with your needs, and ReTreeval learns with you asking questions in an 
easily understood language.

Unlike binary tree programs where each question requires a Yes or No answer, 
Is it red? Yes / No, Is it blue? Yes / No,  ReTreeval will ask, “What colour is it?”  
The answer can be entered from the keyboard, by typing the first few letters, or 
selected from a menu by using the mouse.

In conventional flat file databases we use the analogy of a card index where each 
card is called a record and within it we define fields to describe our record. In 
ReTreeval we shall call each entry a data Item and give it particular Properties 
which describe that item. For example the database may be on Fruit and one of the 
items may be a Lemon. A property of a fruit is its Colour, we say the Colour of a 
Lemon is Yellow. Although this is different from conventional databases, it is more 
like the way we think and describe items that we see in real life.

ReTreeval insists that all items have a unique description. No two items can 
have exactly the same properties. If so, ReTreeval will ask for a new property to 
differentiate between the two.

The features that ReTreeval offers are as follows:

• Uses natural language to ask questions when inputting data

• Data can be entered quickly, and consistently using drop down lists.

• The whole database can be restructured just by pointing, clicking and dragging 
on the tree.

•  Properties can be dependent on the value of other properties.

• The decision tree can be printed across a number of pages to create a large wall 
display or saved out as an Apple Pict file.

• Flat file approach for browsing, searching and editing data.
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System Requirements
• Apple Macintosh running Mac OS 10.2 or higher.

Pictogram is published by Kudlian Software Ltd. The software is the copyright 
of Kudlian Software Limited 1999-2004 and this documentation is copyright of 
Kudlian Software Limited 2004.

If the software was supplied pre-installed on a computer then it is only licensed for 
use on that machine. A separately purchased pack contains a licence which may 
enable it to be used on a number of machines within a single establishment, for 
example a school.

All trademarks are acknowledged.

Kudlian Software Ltd.
8A Nunhold Business Centre

Dark Lane, Hatton, Warwickshire  CV35 8XB
email: support@kudlian.net  web: www.kudlian.net
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Installing ReTreeval
ReTreeval must be installed onto the hard disc in the computer. 

Installing the software onto the hard disc

1 Insert the CD ROM into the CD ROM drive.

2 If you are using Mac OS X ensure you are logged on to the machine as an 
administrator.

3 Drag the appropriate folder to your hard drive.

 For Mac OS 8 and 9 you should use the folder labelled ReTreeval (Classic) and 
for Mac OS X copy the folder labelled ReTreeval (OS X).

 You can place the folders wherever you wish on your system, but we would 
recommend you put them in the Applications folder. 

Registering Your Software
1 Double click the ReTreeval icon in order to run the program.

 The first time that you run ReTreeval you will be asked to enter your licence 
details. If you do not do this ReTreeval will run only in demonstration mode. 
When used in this state the application will not let you save files, print or copy to 
the clipboard.

2 Enter your details 
and the serial number 
in the appropriate 
fields on the start up 
screen.

 Your serial number 
can be found with 
your licence details 
supplied with the 
software.

3 Click on the Register 
button to complete 
the registration 
process.
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Starting ReTreeval
ReTreeval should be installed to the hard disc of you computer. Follow the 
installation instructions supplied with the distribution media. An alias will be added 
to the desktop on your computer.

• Double click on the ReTreeval alias.

 ReTreeval’s start up banner will be displayed on screen for a few moments, 
followed by the main editing window.

 ReTreeval communicates to the user through this window:

Finishing with ReTreeval
To quit ReTreeval:

• Open the ReTreeval application menu and choose the item Quit.

Or;

•  Click on the close window button in the top left hand corner of the main 
ReTreeval window.

 If you have not saved your work, a dialogue box will appear.

• Select the appropriate option.
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Creating Your Own Database
ReTreeval works in three modes, Teach, Test and Browse. When ReTreeval starts it 
is automatically in the Teach mode. If you load one of the example files, e.g. Fruit 
or Mammals, then you can use the Test mode straightaway.

If you are starting a database from scratch you have to tell ReTreeval the subject of 
the database, for example Fruit. Typically these are the types of items that you will 
be talking about.

• Enter the subject of the database into the writable field and click OK.

 ReTreeval will now ask whether each item has a proper name. This determines 
the way ReTreeval phrases its questions, it does not affect the database in any 
other way.

 Items that have proper names are unique, for example; a person has a proper 
name, as does a place or a football team, but items such as fruit, trees, animals 
and minibeasts do not.

You may either:

• Type in the answer Yes / No 

Or 

• Click on the Yes / No buttons.

 These settings can be changed later in the Settings dialogue box.

ReTreeval will now ask you What is the name of the new item? You cannot Stop 
this process until you have entered at least two items. This is because ReTreeval 
requires at least one property to be defined before the database can be saved or 
used intelligently. It is meaningless to only have one item and no defined property.

• Enter the name of the first item and press ENTER

• Enter the name of the second item and press ENTER

 ReTreeval will now ask What can I use to tell ‘item 1’ from ‘item 2’

 The default prompt will read:  What ………………… is it?

If for example you decide that Colour is an appropriate way of telling the difference 
between item 1 and item 2 then the question should read, What Colour is it?

You may decide that this question is not appropriately worded, in which case, if 
you click on the button labelled Question… the Question dialogue box will open, 
allowing you to choose from a range of different types of questions.
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• Select a question from the dialogue box and click on the OK button.

If you choose to use the What _____ is it? or the What _____ has it? type of 
questions, then the answer to the question, (or value of the property), can be text.

The questions Does it have _____? and Is it _____? require a Yes or No answer. 
You cannot give any other type of answer to these questions.

The questions How many _____ has it? and What _____ is it? require numerical 
answers.

The answer to the first question must be a whole number, for example:
How many legs has it? The second question can take any number, for example:  
What height is it?

Once you have chosen a suitable question then ReTreeval will ask you to enter the 
values for the two items you have just entered.

• Enter the values for the two items.

 You have now entered your first two items into ReTreeval. ReTreeval will now ask 
you to enter another new item.

However, it is possible not to enter any items at all if you wish and to just define 
the questions that will be used later. In this way the teacher can setup a template 
for the children who can then later answer some predefined questions for their 
collected data, see page 24.

You can now save your database as a ReTreeval file if you wish.
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Saving Files
• Open the File menu and choose the item Save As…

 The Save As window will open as shown:

• Type in your own file name in the writable field labelled Save As: and click on 
the Save button.

Continue to enter the data for your chosen database. Each time you enter a data 
item ReTreeval will ensure that it has a unique feature that differentiates it against 
all others in the database. If ReTreeval finds it can not differentiate between two 
data items it will automatically prompt you to choose another question in order to 
do so.

Once you have finished entering all of the data you can begin to use the various 
features offered by ReTreeval.

Viewing the Database as a Tree Diagram
The whole of your ReTreeval database can be viewed as a Tree diagram. The 
diagram below uses the Fruits example file. Once the file has been loaded;

• Open the View menu and choose the item Tree.

 The Tree window will open as shown:

The tree diagram gives a visual representation of the database.
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Tree Diagram Settings
• Hold down the CTRL key whilst the mouse pointer is in the tree window and click 

the mouse button.

• Choose Settings… from the pop-up menu.

 The File Settings dialogue will open and the Tree tab will be selected.

The properties which are currently displayed will have a switch to indicate whether 
they are on or off. By default they are all turned on. As the number of properties 
grows so this box also grows with the database. In the above diagram the 
properties displayed are that for the Fruit database.

• Switch off the items Colour and Size.

• Click on the Apply button to confirm the settings, or OK to confirm the settings 
and close the dialogue box.

The tree will now be redrawn showing all the fruits in their respective groups by 
Shape. You will notice that the items Orange and Mandarin are in a group where 
the shape has not been given. This does not matter at the moment because they 
are still uniquely defined by their other properties. You can set the Shape of the 
fruits if you wish, by using the Browse window, see page 14 for more details.

Clicking on the check box on the left hand side of each property will toggle its 
selection. When you uncheck a property it will be temporarily removed from the 
tree diagram. This does not affect the database in any way, it only affects the 
display of the tree diagram.
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Tree display
You can also choose which fonts to use in the tree diagram.
To change the font:

• Click on the General tab in the File Settings dialogue:

ReTreeval uses three different Text Styles;

 Body text – this is the text that is displayed in the main part of the tree diagram.

 Sub-heading –  this is the text which denotes the properties of the data 
items and is displayed down the left hand side of the tree diagram.

 Heading text – this is the text used for the title of the tree diagram and also for 
the title of the graph.

To change any of the text styles:

•  Click on the Font Style… button to the right of the style you wish to change.

 The Font Style window will open and from here you can select the type of font 
you wish to use, its size, style, colour. When you have made your choice click on 
the Apply button and the changes will appear in the diagrams.
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Changing the Structure of the Database
The tree diagram displays the structure of the database. Each item in the database 
is uniquely defined by the values of its properties. In the fruit database this is by 
Colour, then by Size and finally by Shape.

One of the powerful features of ReTreeval is the ease in which the whole database 
can be restructured. In the Fruits database, the user may decide that in order to 
differentiate between the items in a more meaningful way, it might have been 
better to place the ‘shape’ of the fruit higher up the tree than the size.

Lets see this in action:

• Open the example file Fruits provided with ReTreeval.

• Open the tree diagram by choosing Tree from the View menu.

• Move the mouse pointer anywhere along the line of the Shape property, click 
and hold down the mouse button.

 The Shape property will become highlighted, you can ‘drag’ this item up and 
down the tree diagram.

• Drag the item to the gap between Colour and Size.

 The whole of the tree will now be redrawn displaying a different structure.

• Try experimenting by moving other properties up and down the tree.
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Test Mode
By clicking on the Test tab we can test ReTreeval to see whether it knows about 
a particular item. When you click on Test tab, ReTreeval will ask you a number of 
questions to see if it knows about the item you are describing.

Let’s try this with the Fruit database.

• Load the Fruit database and open the Tree diagram.

• Click on the Test tab.

 You will notice that the tree will be coloured with green and yellow blocks. These 
demonstrate how ReTreeval is searching for your item.

 Let’s think of the Orange.

 ReTreeval is asking, What is the Colour of the Fruit?

• Answer this by selecting the colour Orange from the drop down menu, and click 
OK.

 Next ReTreeval will ask you the size of the fruit

• Answer this by selecting the size Medium from the drop down menu.

 Next ReTreeval will ask, What is the shape of the fruit? This may seem a bit 
strange as ReTreeval doesn’t know at this stage the shape of any of the orange 
coloured fruits, so is there any point in asking the is question? We’ll see…

• Answer this by selecting Round from the drop down menu.

 Next ReTreeval will ask you, Is it hairy?

• Answer this as No. 

Finally, ReTreeval will ask you Is the Fruit an Orange?

• Click on the Yes button to confirm that it is an orange.

 As you do so, note that the shape of the Orange is now set to Round, this is 
because although we were testing ReTreeval it has still learned that the fruit was 
round from the answers that we gave to its questions. This behaviour can be 
changed in a setting called Simple Questions. This is in the General tab in the 
File Settings dialogue.

Simple Questions
When this switch is turned on ReTreeval acts slightly differently when in Test mode. 
One difference is that once you have answered enough questions ReTreeval will 
state that This Fruit is a Lime rather than asking Is this Fruit a Lime?  Under 
simple questions, ReTreeval does not learn from you so you cannot add or edit the 
database when testing ReTreeval. With simple questions turned off; ReTreeval can 
be a bit sneaky by asking you questions for which it does not know the answers 
but will add these values into the database once you have confirmed the name of 
the item.
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Creating a Subset
Create Subset allows you to create a subset of the items in the database. Initially, 
you might find it helpful to display all the properties in the tree diagram. The 
example below uses the Fruit database.

• Open the Edit menu and choose the item Create Subset…

 If this item is greyed out then click on the Stop button in the main window.

 The Create Subset dialogue will open:

To help you set up the search criteria the drop down lists will open for the 
properties and their values. Using the Fruits database as before let’s search for 
every fruit whose Colour is Yellow.

First you need to choose the property you wish to search on:

• Using the mouse, choose the Property from the drop down list.

 In the Fruit database we will choose the property Colour.

• Next you need to select an ‘operand’ for the property and value, these are:

 Equals or Not equal

 Less than or Less than or equal

 Greater than or Greater or equal

 These operands can be used for both numeric and textual data. If the values are 
textual then the less than and greater than criteria are used alphabetically. For 
example an Apple is alphabetically smaller than a Banana, because A comes 
before B in the alphabet.

• In our example, we will select Equals

• Next you need to choose a value to match, in our example choose the item 
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Yellow from the drop down list labelled Value.

 At this stage you can choose to extend the search by adding an AND or an OR 
criteria to the search, we will not do this in this example.

• Click on the OK button. The search criteria is now complete and it should read, 
Select every Fruit whose Colour is Yellow.

• Click on OK to use this search criteria.

 If you now look at the tree diagram you will only see those fruits which are 
yellow. The Browse window will also open so that you can browse through the 
database and view those items that have been found. Clicking on the name of 
the fruit in the Tree diagram will take you to that particular fruit in the Browse 
window straight away.

To restore all the items back to the database again:

• Click the Cancel button on the Browser window.

Extended Searches
Searches can be extended to include AND and OR, for example if you wanted to 
find out which fruits were yellow and round.

First ensure that you are using all of the records in the fruit database.

• Open the Edit menu and choose the item All Records.

 Next choose the property you wish to search upon:

• Choose the property from the drop down list.

 In the Fruits database this is the property Colour.

• Select the operand Equals

• Next you need to choose a value to match, in our example choose the value 
Yellow.

 We are now going to extend the search;

• Click on the And button at the bottom of the window.

• Choose the new property from the drop down list.

 In the Fruits database this is the property Shape.

• Select the operand Equals

• Choose the value to match, in our example choose the value Round.

• Click on the OK button. The search is now complete and the search criteria 
should read, Select every Fruit whose Colour is Yellow and Shape is Round.

• Click on OK to use this search criteria.

 If the tree diagram window is open then the tree will be redrawn showing only 
the subset you have just created, and the browse window will appear allowing 
you to look through all the data items in the subset.

 Note: In order to add to the database, test it or carry out a new search you must 
return the database into a state where it is using all records.
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The Browse Window
The Browse feature allows you to edit either the values of the item’s properties or 
to change the properties themselves. If in doing so the object is no longer unique 
then ReTreeval will need to ask you further questions.

Some of the fruits do not have all of their properties defined, for example we do 
not know the Size of a banana, but that is not relevant at the moment because its 
curved shape uniquely identifies it from all the other fruits. Neither does ReTreeval 
know about the shape of an orange or mandarin, this does not matter because 
they are distinguished by their size. We may have to enter this information as the 
database ‘grows’ or we may have to define a new property, for example we may 
ask the question, “Does it have a stone?”

• Click on the Browse tab in the main ReTreeval window.

 The main dialogue will extend as shown:

When browsing the database you are able to look at each item in turn. The item 
number is displayed in the top right hand corner of the window along with the total 
number of items in the database.

•  Clicking on the ‘bumper’ buttons to the left of the item number will move to 
either the next or previous item.
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You can move directly to an item by typing its number in the writable field and 
pressing the ENTER key. If the Tree diagram is open, clicking on the name of an 
item with the mouse will also take straight to that record in the Browse window.

The Browse window allows you to edit the data in a conventional flat file approach. 
When you look at an item you might find that not all of the fields have values. This 
is because ReTreeval might not have had to differentiate between that particular 
item and a similar one in the database. You can either leave these values empty or 
add values where appropriate.

Drop down lists are positioned to the right of each property. These are extremely 
convenient for entering data quickly and easily into the database, they also allow 
data to be entered with greater consistency. The drop down lists can be used from 
the keyboard as well as the mouse.

 Ensure that you have the tree diagram open, as any changes that you make will 
be reflected straight away in the diagram.

• Click on the browse bumper buttons to locate the Orange.

• Because we know that the Orange’s Shape is Round, let’s choose that value 
from the drop down list.

• Click on the OK button to complete the change.

 Notice that the Orange now has its Shape set to Round.

• Try doing the same with the Mandarin.

 All of the fruits now have their shape defined and are obviously divided so far 
into two groups, those that are Round and those that are Curved.

• Try changing the shape of the Lemon to Oval instead of Round.

 Then do the same for the Lime. Notice that the value Oval has now been added 
to the drop down list used for shape. Also notice how the tree diagram has 
changed in structure.

Whilst you are editing the records in this manner it is also worth noting that 
it is also possible to alter the Property details. Any changes that you make 
to a Property on one card will be reflected on all cards and the tree diagram 
immediately it is confirmed.

Editing a Property
In the Fruits example you might want to change the question from What Colour is 
it? to What External colour is it?
To do this:

• Click on the property you wish to alter. In the fruits database we have been 
using, click on Colour

• Edit the text to read External colour

 As soon as you move onto the next record or click on the OK button, the 
changes will be made to all records and the tree diagram.
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Changing the Type of Question
You can also change the type of question being asked. To do this:

• Click on the Browse tab to enter the browse mode.

• Open the Record menu and choose the item Convert Property…

• Select the property whose question you wish to change, then select the type of 
question you wish to use.

Note: It is not always possible to convert from one type of question into another. 
For example you cannot convert from a property that has any answer to a binary 
question with Yes / No answers, but you can convert a binary question to a 
question with any answer.

You can add properties at any time and delete others when they are no longer 
required, but remember; ReTreeval will insist that every item remains unique and 
you cannot delete properties which are still required in order to maintain the items’ 
unique characteristics.

Deleting a Property
To delete a property or question that is no longer required:

• Open the Record menu and choose the item Delete Property…

 Properties can only be deleted if all of its values are empty.

Deleting an Item
To delete an item from the database

• Use the browse window to locate the item you wish to delete.

• Open the Record menu and choose the item Delete Record…

 A confirmation box will ask you to confirm this request.
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Graphing
Another unique feature of ReTreeval is the ability to graph data. Producing a graph 
within ReTreeval is really easy because ReTreeval automatically keeps a count of 
the occurrences of each value for every property.

Plotting a Graph
We’ll use the Fruits database as an example for producing a graph:

• Open the View menu and choose the item Graph.

 The Graph window will open.

 By default you will see a graph of the Colour of the fruits. You will notice that 
ReTreeval also understands colours and it uses the appropriate colours when 
drawing its graphs.

Controlling Data Being Plotted
The first thing you are likely to want to change is the property that is being plotted, 
to do this:

• Move the mouse pointer to the Graph window, hold down the CTRL key and click 
the mouse button.

 This opens the Graph window’s pop-up menu.

• Choose the item Settings…

 The File Settings dialogue will open and Graph Data tab will be automatically 
selected.
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• Click on the pop-up menu labelled Plot (X) and choose Shape.

 In this example it is not possible to plot this data item against another property, 
and this is why the Against button is disabled.

• Click on either the Apply or OK button to confirm your choice.

 The graph will be updated accordingly.

Changing the Graph Type
ReTreeval can display three types of graph; Bar Charts, Line Graphs, Pie Charts 
and, when there are two sets of numerical data, a Scattergram.

• Open the File Settings dialogue and click on the tab labelled Graph Type.

• Select the graph type you wish to view.

• Click on either the Apply or OK button to confirm your choice.

 The graph will be updated accordingly.
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Printing
ReTreeval can produce printouts of the tree diagram, the graph, and a text ‘report’ 
of the items in the database.

To Print a Report
• Open the File menu, open the Print sub-menu and choose the item Report…

 The Print Report dialogue will open as shown:

This enables you to control how the report will be formatted and which properties 
to include.

There are two types of layout, Down the Page and Across the Page. 

This report layout is Down the 
page. The items are listed on the 
left ‘down the page’.

If you wish you can choose to 
switch off the labels by using the 
Include Labels checkbox.

Name Colour Size Shape
Lime Green Small Round

Orange Orange Medium 

Mandarin Orange Small  

Apple Red Medium Round

Banana Yellow Curved

Grapefruit Yellow Large Round

Lemon Yellow Medium Round
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The layout below is Across the page.

Name Apple Banana Grapefruit Lemon Lime Mandarin Orange
Colour Red Yellow Yellow Yellow Green Orange Orange

Size Medium Large Medium Small Small Medium

Shape Round Curved Round Round Round

You can also sort all the items into alphabetical order, by name, using the Sort (by 
name) switch.

You can also choose with properties you wish to include in the report by clicking 
on their switches in the scrollable list labelled Properties.

To Print the Graph
• Open the File menu, open the Print sub-menu and choose the item Graph…

To Print the Tree Diagram
• Open the File menu, open the Print sub-menu and choose the item Tree…
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Exporting Files
Exporting the Report as a Text File
You can also export all the data in the database as a text file. The options in the 
dialogue window are exactly the same and the text is formatted in the same way.

To export a report:

• Open the File menu, open the Export sub-menu and choose the item Report…

 The Export Report dialogue will open, similar to the Print Report dialogue.

• Select the options you require to format your report.

• Click on the Export button to save your report.

 A Save Report As dialogue will open prompting to save the file in the usual way.

Exporting the Tree Diagram
The tree diagram can also be exported as an Apple Pict file. This is a type of 
graphic file that can be placed into many word processors and DTP programs.

To export the tree diagram:

• Open the File menu, open the Export sub-menu and choose the item Tree…

 A Save Tree As dialogue will open prompting to save the file in the usual way.

 The saved file can then be imported into other applications.

Exporting the Graph
The graph can also be exported as an Apple Pict file.

To export the graph:

• Open the File menu, open the Export sub-menu and choose the item Graph…

 A Save Graph As dialogue will open prompting you to save the file in the usual 
way.

 The saved file can then be imported into other applications.

Copying the Tree Diagram and Graph to the Clipboard
The tree diagram and the graph can also be copied to the clipboard so that they 
can be pasted into other applications. This method is slightly more convenient than 
saving and loading files.

To copy either diagram to the clipboard:

• Open the required view of either the tree or the graph.

• Format the graph or tree diagram as you require.

• On the appropriate diagram, hold the CTRL key and click the mouse button to 
open the diagram’s pop-up menu.
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• Choose the item Copy Tree or Copy Graph.

 The diagram will now be placed on the clipboard and is ready to be pasted into 
another application.

Relating Properties
Another powerful feature of ReTreeval is the ability to relate one property to 
another. For example if you were looking at minibeasts and asked ‘Does the 
minibeast have legs?’ If the answer was Yes then we can go on to ask ‘How many 
legs does the minibeast have?’, but it is somewhat pointless to ask this if it has no 
legs. In this way we say that the ‘number of legs’ property is dependant on whether 
the minibeast has legs or not.

Let’s look at how we can make one property dependant on another.

• Open the example file Minibeasts.

• Open the tree diagram so we can view the database.

 You will notice that we have a question on whether the minibeast has legs or not, 
then further down we go on to ask how many pairs of legs per segment does the 
minibeast have. We are going to change this so that if the answer to the Legs 
question is No it does not then ask the other two questions.

• Open the Edit menu and choose the item Relate Properties…

 The Relationships dialogue will open as shown.

 This dialogue displays all of the defined relationships between properties. In this 
example there are not yet any relationships.

• Click on the New… button to define a new relationship.
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This will open the Edit Relationship dialogue as shown:

We define the relationship between a Parent and a Child. In this case the parent is 
the property Legs and the children will be the other two properties.

• Click on the drop down list labelled Parent and choose the property Legs.

• Select the option button labelled Must be

• Enter the text Yes into the writable field to the right of the option buttons.

• Click on the drop down list labelled Child and choose the property pairs of legs.

• Click on the OK button to confirm this relationship.

 The relationship will now appear in the list in the relationships dialogue.

• Click on the New… button once more and do the same thing again but this time 
with the less than 14 pairs of legs property.

• Finally click on Done to close the relationships dialogue.

Now let’s test ReTreeval to see if these new relationships are working correctly.

• Click on the Test tab to go to test mode.

 The first question is Does the Minibeast have legs?

• Answer No

 ReTreeval will now ask you a number of other question, but these will not include 
the two you have just setup with relationships.

• Confirm that it is a snail by clicking on the Yes button and do the same thing 
again but this time answer Yes to the question about whether the minibeast has 
legs.

 ReTreeval will now go on to ask you questions about the number of pairs of legs 
per segment etc.
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Setting Up a Template
It is possible to setup a template in ReTreeval that allows the user to enter only 
questions into the database. The children are then able to answer these questions, 
using their collected data, at a later date.

Creating a Template

• Load the ReTreeval application.

 You will need to answer the first few questions in the usual way. In the following 
example we are going to use woodland birds, but feel free to enter your own 
questions if you wish.

 In response to Everything we are going to talk about is a…

• Enter Bird

 You will then be asked if each item has a proper name;

• Click on the No button

 Normally you would now start to enter some items, in this example, the names 
of birds, but in this instance we only want to enter the questions.

• Choose Add Question from the Edit menu.

 A prompt will appear asking you to Complete the question. You can either use 
the default question or use another one more appropriate to the question you 
wish to ask.

• Click on the Question… button

 The Question dialogue will open.

• Click on the option Does it have……….?

• Click on the OK button.

 The question will now change to Does it have……..?

• Enter the text Black feathers into the writable field.

• Click on the OK button.

 The dialogue will now revert back to the usual ReTreeval ‘teach’ mode.

 Let’s add another question:

• Choose Add Question from the Edit menu.

• Click on the Question button  to open the Question dialogue.

• Choose the option Does it have……….? then click on OK.

• Enter the text an orange beak into the writable field.

• You can carry on and enter all of the questions in this way.

• Remember to regularly save your work.

• Open the File menu and choose Save.

 The Save As dialogue will open.

• Choose where you are going to save your work to and give the file an 
appropriate name.
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 Complete your database entry by using the 
following questions:

• What approximate length is it?

• Does it have bright red feathers?

• Does it have a red face?

• What colour breast feathers has it?

• Is it speckled?

• Is it Brown?

• Does it have a speckled breast?

• Is it speckled all over?

 You can continue to enter more questions 
if you wish. 

• Save your database before continuing any 
further.

• Click on the Stop button.

 You are now ready to enter data. If you 
already know some examples of British 
woodland birds then use them, if not;

• Enter in the name of the new bird, 
Blackbird.

• Click on the OK button or press the ENTER 
key.

 You will be asked if the bird has black 
feathers.

• Click on the Yes button.

Then proceed with the next question. You 
do not have to answer every question, you 
can just keep clicking on the OK button until 
ReTreeval asks you for the name of the next 
bird. If you enter two birds with exactly the 
same properties then ReTreeval will ask you 
to differentiate between the two birds. You 
can do this by either entering a new question 
or by selecting one of the questions that have 
already been entered from the drop down list.

The tree diagram can be opened as soon as 
you start to enter data. Each time you then 
enter a bird the path you are taking through 
the questions is highlighted and the bird will 
immediately appear on the Tree diagram 
once you have finished entering all questions 
about it.
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Associating Files with Items
It is possible to link an item in the database to an external file located somewhere 
on your system. The file can be of any type, and when you ask ReTreeval to show 
the file it will attempt to run the file, so that it will load into the default application 
for displaying that type of file. You can also link to an application which will be 
launched when you click on Show.

To link an item to a file:

• Click on the Browse tab to extend the main window.

 You will note there are two buttons at the bottom of the window, Select… and 
Show. If there is no file linked to the item then the Show button will be disabled.

• Click on Select… to open a browser dialogue where you can select a file or 
application to link to the item.

 When you have done this the Show button will be enabled.

• Click on the Show button to launch the file or application.

 If the linked file is moved, deleted or renamed then a message box will appear 
explaining that the file cannot be found.


